icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.newhairproducts.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

大发28彩票 www.490822.com-彩神大发邀请码| www.092214.com-kc一分彩-| www.212569.com-凤凰私彩平台怎么进| www.992272.com-时时彩百位如何定胆| www.es24.com-彩神网站app下载| www.713433.com-福彩彩票开奖查询| www.31898.cc-竞彩足球即时开奖| www.662907.com-天津体彩开奖| www.812664.com-华彩咨询集团| www.971624.com-中华彩票网址app| www.jw12.com-彩铅零基础-| 大赢家彩票平台www.068657.com| www.351036.com-接手彩票店风险| www.27fv.com-网上有人带你玩福彩| www.621659.com-买彩票的地方叫什么| www.948604.com-彩票5选3中奖规则| www.nl73.com-竞彩分析推荐唯彩网| www.932561.com-山东体彩网助学| www.91935.cc-1717广东彩王| www.732923.com-下载江苏体彩七位数| www.815082.com-中国福利彩票排列七| www.896127.com-中彩神-| www.968296.com-8828彩票靠谱吗| 天天中彩票www.836595.com| www.308211.com-彩票777正规吗| www.380652.com-鲁豫有约彩票人生| www.503717.com-胆略足彩app| www.819308.com-彩票必中高手| www.476642.com-湖北福彩快三新规| www.34564.cc-福彩三d今天奖号| www.oe74.com-长春福彩中心网站| www.678662.com-吉利快三1分钟1期| www.831115.com-人工智能彩票选号| www.898759.com-体育彩票排列三玩法| www.966552.com-篮球彩票比分直播| 彩客网www.590979.com| www.65866.com-宜昌快三中奖| www.131647.com-最近河南彩票中奖| www.yk62.com-大乐购彩票中奖号| www.342422.com-期期743好彩| www.560873.com-我要中彩票软件下载| www.128020.com-天天好彩彩票资料天| www.765526.com-乐盈彩票可信吗| www.742128.com-四川体育彩票地址| www.863998.com-福彩领奖时间周六日| www.973995.com-132.com彩票| www.na01.com-江西快三下载| www.zf72.com-大发云彩票系统| www.673.cm-国家关闭重庆时时彩| www.461953.com-彩票藏机图天气网| www.659439.com-彩俐-| www.009956.com-彩票筛子有规律吗| www.722479.com-时时彩高手论坛| www.034406.com-篮球竞彩推荐| www.929679.com-1七星1七星彩| www.273009.com-五分快三全天计划网| www.668051.com-福彩3d太阳红字谜| www.16627.cc-万彩网官网-| 500彩票www.401286.com| www.426132.com-五福彩彩票最新开奖| www.39vj.com-50707巨峰彩票| www.38269.cc-四川省福彩管理中心| www.017716.com-中福彩票开奖网站| www.62gd.com-下彩彩-| www.2469.cn-王成周中彩票的公式| www.8917.live-竞彩第二天几点兑奖| www.266075.com-今日福彩号码预测| www.41299.cc-中彩中彩-| www.s12.com-广西快三玩法| www.7630.vip-天空彩票金彩网| www.997705.com-keno彩票-| www.of95.com-足彩网比分直播| www.2277.live-彩票单式不好中| www.278298.com-599彩票苹果版| www.355974.com-龍之彩下载-| www.50es.com-烟台体彩管理中心| www.1457.cc-初中彩铅画-| www.33747.cc-彩票买哪种好大奖大| www.3468.net-新快三走势图安徽| www.338877.com-大发购彩大厅| www.418088.com-一号彩票安卓版下载| www.523739.com-快刀时时彩软件| www.586616.com-彩金送9快棋牌| www.651144.com-花图片水彩-| www.994806.com-好彩堂一句一肖| www.py2.cc-吉林福彩时时彩| www.nw83.com-吉林快三和值和跨度| www.218800.cc-大发快三代理加盟| www.332805.com-彩票直播频道| www.404073.com-新手彩铅画临摹素材| www.503875.com-中国体育彩票充号| www.017997.com-开彩票站-| www.115102.com-福彩投注大厅| www.45079.com-江苏快3彩乐乐| www.606326.com-足彩爆冷怎么预测| www.267936.com-一分快三在线计划| www.889854.com-98年彩票最大奖| www.785225.com-大胜彩票安卓最新| www.338116.com-超级彩下载-| www.477417.com-江西福彩开奖| www.576338.com-红五3b彩报-| www.672058.com-彩票行业会倒闭吗| www.959043.com-上海福利彩票店转让| www.yw72.com-3d彩票技巧和规律| www.697087.com-安卓系统足球彩票| www.277210.com-五分钟就开的彩票| www.229223.com-洛阳快三开奖结果| www.323008.com-福利彩票双色球双| www.05ue.com-国产彩电什么牌子好| www.74211.com-彩票1216app| www.13li.com-七乐彩下注规则| www.879917.com-极速彩3-| www.941573.com-三星彩票娱乐兼职| www.7238.cm-彩虹六号机票多少钱| www.197755.com-排三乐彩17500| www.256976.com-百度福彩3d字之谜| www.277653.com-大平台彩票-| www.p92.xyz-易发彩-| www.391155.com-海南私彩大奖软件| www.446569.com-巨丰彩票正规合法吗| www.947262.com-三地彩吧图庫| www.808516.com-e乐彩会员线路| www.984384.com-甘肃体彩下载软件| www.983485.com-彩88是真的吗| www.99229.cc-极速时时彩五星算法| www.e69.club-竞彩258-| www.91mh.com-福彩今日期藏机图| www.745727.com-中彩彩票万人牛牛| www.558645.com-胜负彩任九-| www.57554.com-澳客彩票售后电话| www.227931.com-大发快三和值计划| www.nn46.com-竞彩篮球投注app| www.e91.cc-中国福彩网开奖时间| www.253342.com-分分时时彩开奖网| www.858419.com-三彩官方旗舰店毛衫| www.353639.com-彩票加盟代理多少钱| www.h09.top-中彩网3d开奖公告| www.883035.com-万豪国际彩票| www.982467.com-新加坡天天彩资讯网| www.ii69.cc-福彩在线购买app| www.17rr.com-app刷彩网-| www.864.tv-19019体彩-| www.rd03.com-大发快三算号器| www.1008.cc-星期一三五开的彩票| www.608565.com-派彩合法不-| www.46364.com-自动售卖福彩彩票机| www.607290.com-历史最高彩票奖金| www.04004.com-育彩福利彩票开奖| www.109829.com-红牛快三计划软件| www.220608.com-中原彩票网中原网| www.139887.com-绵阳福彩分中心官网| www.189673.com-河南快三3012| www.2455.in-竞彩足球全包法| www.oi88.com-彩票巨奖死亡| www.75fz.com-七星彩领奖日期| www.5563.cc-哪里有彩票计划软件| www.565550.com-足彩看盘杀招| www.858161.com-安徽快三最新走势图| www.968040.com-福彩14人涉贪| www.dn58.com-快三遗漏号数据查询| www.4vs.com-福彩中奖如何领取| www.296112.com-三的跨度走势图福彩| www.vj67.com-双色球彩票规则介绍| www.95996.com-体彩专管员压力|